AkelPad Forum Index AkelPad
Support forum
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Alt Characters Not Working in AkelPad 4.3.0
Goto page 1, 2  Next
 
Post new topic   Reply to topic    AkelPad Forum Index -> Discussion (English)
View previous topic :: View next topic  
Author Message
dypsis



Joined: 01 Sep 2009
Posts: 14

PostPosted: Tue Sep 01, 2009 8:29 pm    Post subject: Alt Characters Not Working in AkelPad 4.3.0 Reply with quote

I just upgraded from v4.2.6 to v4.3.0.

Before I upgraded, Alt Characters were working.
Immediately after upgrading, I cannot get Alt Characters to work.

For example:
I tried to use Alt + 175 =

I now have to use Notepad, and copy it to AkelPad.

And suggestions? Rolling Eyes
Back to top
View user's profile Send private message
Surveyor



Joined: 08 Feb 2008
Posts: 146
Location: British Columbia, Canada

PostPosted: Tue Sep 01, 2009 9:49 pm    Post subject: Reply with quote

Welcome aboard!
dypsis wrote:
Immediately after upgrading, I cannot get Alt Characters to work.

Instructor has informed us that the NumLock must be on. Also, Alt+nnn must be done from the numeric keypad (obvious?); when NumLock is off, the navigation keys are active (Home, End, etc.) so Alt+nnn does not work. I suppose it bears mentioning that Alt+nnn can only represent characters that are available in your current display font - you can use the Character Map (Ctrl+I) to see which characters are available.

Other than that, it should work! Do another post with more details if it does not (Windows version, other applications in background, etc.).
Back to top
View user's profile Send private message Send e-mail
FeyFre



Joined: 07 Aug 2007
Posts: 2033
Location: Vinnitsa, Ukraine

PostPosted: Tue Sep 01, 2009 9:51 pm    Post subject: Reply with quote

Try ALT+187 (in my environment 175 is "¯" not "")
Back to top
View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger
dypsis



Joined: 01 Sep 2009
Posts: 14

PostPosted: Tue Sep 01, 2009 10:40 pm    Post subject: Reply with quote

FeyFre wrote:
Try ALT+187 (in my environment 175 is "¯" not "")

Have a look here at the Alt Codes reference sheet.

Or check out other Alt Codes sites. Wink


Last edited by dypsis on Wed Sep 02, 2009 12:00 am; edited 2 times in total
Back to top
View user's profile Send private message
dypsis



Joined: 01 Sep 2009
Posts: 14

PostPosted: Tue Sep 01, 2009 10:43 pm    Post subject: Reply with quote

Surveyor wrote:
Welcome aboard!
dypsis wrote:
Immediately after upgrading, I cannot get Alt Characters to work.

Instructor has informed us that the NumLock must be on.
Other than that, it should work! Do another post with more details if it does not (Windows version, other applications in background, etc.).

Yes, I am aware of all the above. I am using the same font. I kept the same AkelPad.ini.

I have just gone back to v4.2.6, and it is working fine. It is only a problem with v4.3.0.
Back to top
View user's profile Send private message
Instructor
Site Admin


Joined: 06 Jul 2006
Posts: 5293

PostPosted: Wed Sep 02, 2009 12:09 am    Post subject: Reply with quote

dypsis
What character you get after Alt+187 and Alt+0187?
Back to top
View user's profile Send private message Send e-mail
dypsis



Joined: 01 Sep 2009
Posts: 14

PostPosted: Wed Sep 02, 2009 12:32 am    Post subject: Reply with quote

Instructor wrote:
dypsis
What character you get after Alt+187 and Alt+0187?

Nothing. It does nothing at all using v4.3.0.
Back to top
View user's profile Send private message
dypsis



Joined: 01 Sep 2009
Posts: 14

PostPosted: Wed Sep 02, 2009 12:34 am    Post subject: AkelPad Plugins Reply with quote

In case this is caused by a Plugin conflict, here are the Plugins I am using.

MinimizeToTray v2.7
QSearch v2.2
RecentFiles v1.7
ToolBar v4.7


Autoload:

MinimizeToTray::Always
QSearch::DialogSwitcher
Toolbar::Main
Back to top
View user's profile Send private message
dypsis



Joined: 01 Sep 2009
Posts: 14

PostPosted: Wed Sep 02, 2009 12:51 am    Post subject: Reply with quote

I turned off Autoload on the above Plugins, and restarted, but it still doesn't work. Sad
Back to top
View user's profile Send private message
Instructor
Site Admin


Joined: 06 Jul 2006
Posts: 5293

PostPosted: Wed Sep 02, 2009 12:51 am    Post subject: Reply with quote

dypsis
1. Open character map "Main menu->Edit->Insert character (Ctrl+I)"
2. Find "" character and see in status bar what Alt+Number you should type.

What character you get after Alt+175 and Alt+0175? From what country you are? What default codepage you have?
Back to top
View user's profile Send private message Send e-mail
dypsis



Joined: 01 Sep 2009
Posts: 14

PostPosted: Wed Sep 02, 2009 3:01 am    Post subject: Character Map Reply with quote

@ Instructor.

Alt + 0187 appears to be the character in the Character Map.

But I cannot add it using the the Alt Codes. In fact, I cannot add any characters using Alt Codes.
But I can add them fine in Notepad and AkelPad v4.2.6.

I am in Australia.

Default Codepage: 1251 (ANSI - Latin 1)
I have tried a few different Ddefault Codepages, without luck.
Back to top
View user's profile Send private message
Instructor
Site Admin


Joined: 06 Jul 2006
Posts: 5293

PostPosted: Wed Sep 02, 2009 4:54 am    Post subject: Reply with quote

dypsis
Quote:
In fact, I cannot add any characters using Alt Codes.
Strange. Try this version. What you see?
Back to top
View user's profile Send private message Send e-mail
Surveyor



Joined: 08 Feb 2008
Posts: 146
Location: British Columbia, Canada

PostPosted: Wed Sep 02, 2009 6:38 am    Post subject: Reply with quote

dypsis,
dypsis wrote:
Default Codepage: 1251 (ANSI - Latin 1)

I hope this is a typo - 1251 is Cyrillic on my machine (XP SP2)!
You might also have a look here, re: trashing current registry settings.
Also, apparently some keyboard drivers may only recognize the left Alt key - try both.
Back to top
View user's profile Send private message Send e-mail
dypsis



Joined: 01 Sep 2009
Posts: 14

PostPosted: Wed Sep 02, 2009 8:31 pm    Post subject: Reply with quote

Surveyor wrote:
dypsis,
dypsis wrote:
Default Codepage: 1251 (ANSI - Latin 1)

I hope this is a typo - 1251 is Cyrillic on my machine (XP SP2)!
You might also have a look here, re: trashing current registry settings.
Also, apparently some keyboard drivers may only recognize the left Alt key - try both.

Sorry, It is a typo. This is what it is.

Default Codepage: 1252 (ANSI - Latin 1)
Back to top
View user's profile Send private message
dypsis



Joined: 01 Sep 2009
Posts: 14

PostPosted: Wed Sep 02, 2009 8:35 pm    Post subject: Reply with quote

Instructor wrote:
dypsis
Quote:
In fact, I cannot add any characters using Alt Codes.
Strange. Try this version. What you see?

It is working. Smile

But I get a popup error message.
It says.

0.Char=[-2]

So why is v4.2.6 working fine, but not v4.3.0? Confused
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    AkelPad Forum Index -> Discussion (English) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


SourceForge.net Logo Powered by phpBB © 2001, 2005 phpBB Group