AkelPad Forum Index AkelPad
Support forum
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Bug reports
Goto page Previous  1, 2, 3, 4, 5 ... 11, 12, 13  Next
 
Post new topic   Reply to topic    AkelPad Forum Index -> Discussion (English)
View previous topic :: View next topic  
Author Message
ak0



Joined: 13 Sep 2012
Posts: 3

PostPosted: Thu Sep 13, 2012 2:56 pm    Post subject: Reply with quote

Hello, it is not possible to insert a backslash (\) into the editor through using the normal key combination with Ctrl + Alt.

4.7.9.0 x64 on Windows 7 with German keyboard layout and all AkelPad settings at default.
Back to top
View user's profile Send private message
Instructor
Site Admin


Joined: 06 Jul 2006
Posts: 5402

PostPosted: Thu Sep 13, 2012 6:52 pm    Post subject: Reply with quote

ak0
Turn off or change hotkey:
"Plugins...->Coder::Settings->CodeFold 2->All levels->Previous level"
Back to top
View user's profile Send private message Send e-mail
FeyFre



Joined: 07 Aug 2007
Posts: 2054
Location: Vinnitsa, Ukraine

PostPosted: Thu Sep 13, 2012 7:15 pm    Post subject: Reply with quote

Instructor, "All levels->Previous level" is Ctrl + Alt + [ on EN which must be "Ctrl + Alt + ü" on DE not "Ctrl + Alt + ß". Very strange.
Back to top
View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger
ak0



Joined: 13 Sep 2012
Posts: 3

PostPosted: Thu Sep 13, 2012 7:16 pm    Post subject: Reply with quote

Removed all assigned hotkeys from the coder plugin but it's still not possible to write the backslash. It must be something other than the plugin because the problem persists even with the coder.dll deleted.
Back to top
View user's profile Send private message
AEN007



Joined: 14 Sep 2012
Posts: 7

PostPosted: Fri Sep 14, 2012 1:51 pm    Post subject: Reply with quote

14September2012

Greetings.
I am "trying out" AkP 4.79 (nosetup&ini).
The main menu has &View and &Window, but Alt-V and Alt-W do not call those items;
in fact Alt-V functions like Ctrl-V (i.e., paste).

I loaded the AkP.exe into Resource Hacker and changed &View to Vie&w and &Window to &Tabs and deleted»
Code:
VK_W, 4122, NOINVERT, ALT, VIRTKEY

Then Alt-W calls Vie&w and Alt-T calls &Tabs.
Deleting»
Code:
VK_V, 4192, NOINVERT, ALT, VIRTKEY
has no effect.
Ctrl-Shift-V (always) functions like Ctrl-V as well ...
Back to top
View user's profile Send private message
FeyFre



Joined: 07 Aug 2007
Posts: 2054
Location: Vinnitsa, Ukraine

PostPosted: Fri Sep 14, 2012 2:18 pm    Post subject: Reply with quote

AEN007
Use HotKeys plugin to reassign hotkeys.
Alt+V has a bit different function(columnar pasting) than Ctrl+V(standard pasting).
Ctrl+Shift+V is past as ANSI(helpfull when some other program breaks clipboard).
See AkelHelp-Eng.htm
Back to top
View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger
Instructor
Site Admin


Joined: 06 Jul 2006
Posts: 5402

PostPosted: Fri Sep 14, 2012 2:51 pm    Post subject: Reply with quote

ak0
Standalone AkelPad.exe has the same effect?

Currently I have no Win7 for testing.
Back to top
View user's profile Send private message Send e-mail
ak0



Joined: 13 Sep 2012
Posts: 3

PostPosted: Fri Sep 14, 2012 3:44 pm    Post subject: Reply with quote

Yes, the same without any plugins.


AltGr + Ctrl + ß can write the backslash.
Back to top
View user's profile Send private message
AEN007



Joined: 14 Sep 2012
Posts: 7

PostPosted: Fri Sep 14, 2012 4:42 pm    Post subject: Reply with quote

14September2012

OK ...
I had already downloaded the HotKeys plugin but have not had time yet to check it out ...
I see how I can assign hotkeys but do not see (yet )
how to delete existing hotkeys ... like Alt-W, Alt-V, Escape ...
(How) Can that be done?

In any case the main menu should not have &View and &Window
when Alt-V & Alt-W are assigned as hotkeys to other functions!

EDIT: The "Words delimiters:" are giving me a problem ...
When "Wd" is disabled, Ctrl-Left/Right moves to caret to the beginning of each word after any space(s); but
when "Wd" is enabled, Ctrl-Left/Right loses that functionality ... seems to me that functionality should remain in effect ...
is there some way to configure "Words delimiters:" to keep that effect?
Back to top
View user's profile Send private message
KDJ



Joined: 06 Mar 2010
Posts: 1396
Location: Poland

PostPosted: Fri Sep 14, 2012 5:34 pm    Post subject: Reply with quote

AEN007 wrote:
how to delete existing hotkeys ... like Alt-W ...

Read Hotkeys-Eng.txt.
In Hotkeys plugin:
Name: Disable Alt+W
Command: Command(-1)
Hotkey: Alt+W

AEN007 wrote:
The "Words delimiters:" are giving me a problem ...

Read AkelHelp-Eng.htm -> Manual settings -> WordBreak.
Set in AkelPad.ini (or in registry):
WordBreak=5
Back to top
View user's profile Send private message
AEN007



Joined: 14 Sep 2012
Posts: 7

PostPosted: Fri Sep 14, 2012 6:30 pm    Post subject: Reply with quote

14September2012

OK ... thanks ...
I have now put WordBreak in place how I would like it ... great ...

I had already opened and looked at Hotkeys-Eng.txt and didn't find it too "user-friendly",
so thanks for spelling it out for me ...

I find that the following»
Name: Disable Alt+V
Command: Command(-1)
Hotkey: Alt+V
makes Alt-V fire BOTH &View and columnar paste ...

I find that the following»
Name: Disable Alt+V
Command: Command(0)
Hotkey: Alt+V
kills Alt-V totally ...

I can find no way to enter a Esc as hotkey to disable
because hitting escape closes the plugin popup ...
I suppose one would have to know how to tweak the HotkeyText= line in hotkeys.ini ...???
Back to top
View user's profile Send private message
Instructor
Site Admin


Joined: 06 Jul 2006
Posts: 5402

PostPosted: Fri Sep 14, 2012 7:22 pm    Post subject: Reply with quote

AEN007
User Friendly documentation

AEN007 wrote:
makes Alt-V fire BOTH &View and columnar paste ...
Fixed. Will work for 4.8.0.
Quote:
I can find no way to enter a Esc as hotkey to disable
Escape key has special meaning and tuned with Exit plugin.
Back to top
View user's profile Send private message Send e-mail
AEN007



Joined: 14 Sep 2012
Posts: 7

PostPosted: Fri Sep 14, 2012 7:28 pm    Post subject: Reply with quote

14September2012

... well for whatever it is worth I submit that I don't like for ESC to close my apps.
I have seen other apps that allow users to choose whether ESC will close the app or not ...
Back to top
View user's profile Send private message
KDJ



Joined: 06 Mar 2010
Posts: 1396
Location: Poland

PostPosted: Fri Sep 14, 2012 7:44 pm    Post subject: Reply with quote

AEN007
Exit plugin:
1. Select autoload Exit::Main
2. Run Exit::Settings and choose Escape->Ignore
Back to top
View user's profile Send private message
KDJ



Joined: 06 Mar 2010
Posts: 1396
Location: Poland

PostPosted: Fri Sep 14, 2012 9:08 pm    Post subject: Reply with quote

I found a way to disable Esc key using Hotkeys plugin and script (without using Exit plugin):
1. Run script PluginText.js.
2. Select Hotkeys on the plugins list.
3. Press button "Save plugin text in text file (F2)".
4. Press button "Edit text file (F4)".
5. In text file Hotkeys.HotkeyText.akelmenu add new line:
   "Disable Esc" Command(0) Hotkey(27)
   and save this file.
6. Press button "Load text file to plugin key (F5)".
7. Close script and AkelPad.
8. Run AkelPad. Now Esc is disabled.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    AkelPad Forum Index -> Discussion (English) All times are GMT
Goto page Previous  1, 2, 3, 4, 5 ... 11, 12, 13  Next
Page 4 of 13

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


SourceForge.net Logo Powered by phpBB © 2001, 2005 phpBB Group