AkelPad Forum Index AkelPad
Support forum
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Bug reports
Goto page Previous  1, 2, 3 ... 11, 12, 13
 
Post new topic   Reply to topic    AkelPad Forum Index -> Discussion (English)
View previous topic :: View next topic  
Author Message
Instructor
Site Admin


Joined: 06 Jul 2006
Posts: 6225

PostPosted: Sun Aug 24, 2014 9:26 am    Post subject: Reply with quote

maki
1. Seems that you edit binary file. Space that you mention is NULL symbol (you can check it with HexSel plugin or with %ch variable of manual parameter StatusUserFormat). To replace it use regexp "\x00" or esc-sequence "\[0000]".
2. See first point. Other applications will read text only to first NULL, but you can copy/paste text with NULL symbols between AkelEdit controls.
Back to top
View user's profile Send private message Send e-mail
maki



Joined: 20 Aug 2014
Posts: 49

PostPosted: Fri Sep 05, 2014 4:11 pm    Post subject: Reply with quote

Quote:
To delete empty lines, you should use "Replace" dialog with "Regular expressions" parameter and "What" eg:
Code:
^[ \t]*$\n*


ALL OTHER editor does not require the use of stupid regex remove a line, space, etc. ..
This is awful stupid.
Sorry for the criticism but I had to say it.
Back to top
View user's profile Send private message
Noomen



Joined: 04 Jul 2016
Posts: 1

PostPosted: Mon Jul 04, 2016 2:59 pm    Post subject: Bug Report Reply with quote

Dear developer,

First I would like to thank you for this amazingly practical piece of software that you wrote. Impressively fast and lightweight. Thank you.

Now I would like to report on a bug, I think, that exists in Akelpad. When I want to save a file, I always have to put the extension, which is most of the time just a simple txt, by hand. I know that there is an option that does it automatically, but that option doesn't work. Even if you check the box, default extension txt, the default extension that comes up when you try to save is always blank. I am not sure whether it is me or it is really a bug.

Would be grateful if you could take a look at this.

Thanking you in advance.

Best regards,
Back to top
View user's profile Send private message
Instructor
Site Admin


Joined: 06 Jul 2006
Posts: 6225

PostPosted: Tue Jul 05, 2016 7:21 am    Post subject: Reply with quote

Noomen
Not reproduced. What OS? Default extension is "txt" (Options -> Settings... -> Advanced -> default saving extension)? In save dialog try to change files type listbox to "Text files (*.txt)".
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    AkelPad Forum Index -> Discussion (English) All times are GMT
Goto page Previous  1, 2, 3 ... 11, 12, 13
Page 13 of 13

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


SourceForge.net Logo Powered by phpBB © 2001, 2005 phpBB Group