AkelPad Forum Index AkelPad
Support forum
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

AP crashes if PaintOptions has bit 8 set

 
Post new topic   Reply to topic    AkelPad Forum Index -> Discussion (English)
View previous topic :: View next topic  
Author Message
tmsg



Joined: 21 Aug 2012
Posts: 27
Location: UK

PostPosted: Fri Aug 24, 2012 3:04 pm    Post subject: AP crashes if PaintOptions has bit 8 set Reply with quote

AP 4.7.8; XP fully patched; AP options in INI file.

My PaintOptions are set to 1281, ie 1024+256+1.

If I call View/Split window AP crashes after partially painting the first sub window (ie top left).

If I set PaintOptions to 1025, everything works.

TM
Back to top
View user's profile Send private message
Infocatcher



Joined: 06 Aug 2007
Posts: 1612

PostPosted: Fri Aug 24, 2012 3:15 pm    Post subject: Reply with quote

The same issue (translation)? (See link to test version in next message)
And I'm use PaintOptions=256.
Back to top
View user's profile Send private message Visit poster's website
tmsg



Joined: 21 Aug 2012
Posts: 27
Location: UK

PostPosted: Fri Aug 24, 2012 3:53 pm    Post subject: Reply with quote

Infocatcher wrote:
The same issue (translation)? (See link to test version in next message)
And I'm use PaintOptions=256.

Possibly.
Here, a freshly unzipped AP 4.7.8, w/o any plugins installed, crashes reliably if PaintOptions has 256.
If I understand the other thread correctly, the test version uploaded 19/08 by Instructor worked for you?

TM
Back to top
View user's profile Send private message
Infocatcher



Joined: 06 Aug 2007
Posts: 1612

PostPosted: Fri Aug 24, 2012 4:23 pm    Post subject: Reply with quote

tmsg wrote:
If I understand the other thread correctly, the test version uploaded 19/08 by Instructor worked for you?

Yes, version 4.7.9dev (md5: 80eecf0f921e82ee51a23156fd8d71b4) works fine for me.
Back to top
View user's profile Send private message Visit poster's website
tmsg



Joined: 21 Aug 2012
Posts: 27
Location: UK

PostPosted: Fri Aug 24, 2012 4:34 pm    Post subject: Reply with quote

Infocatcher wrote:
tmsg wrote:
If I understand the other thread correctly, the test version uploaded 19/08 by Instructor worked for you?

Yes, version 4.7.9dev (md5: 80eecf0f921e82ee51a23156fd8d71b4) works fine for me.

I can confirm that this version doesn't crash. Bug squashed;-)

TM
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    AkelPad Forum Index -> Discussion (English) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


SourceForge.net Logo Powered by phpBB © 2001, 2005 phpBB Group